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Data visualization transforms data into powerful visualizations and provides 
tactical, operational, and strategic insights. No longer merely a spreadsheet, 
business intelligence visualizations can be used for everything from providing 
analysis of cybersecurity patterns, to managing workplace efficiency for global 
companies.

—Jason Beres, Sr. VP of Developer Tools at Infragistics

Overview
Spreadsheets are electronic documents that help users to manipulate data. While word processors 
and email are probably the most used productivity applications, much of the world’s business runs on 
spreadsheets. This is because spreadsheets are productivity applications designed to store numbers. 
Spreadsheets make it easy to visualize data and identify trends in that data. Any teacher tracking 
student grades will find it easiest to do so using spreadsheets. Student clubs will find it easiest to track 
contributions and expenses if they use spreadsheets. You may not use spreadsheets every day of your 
life, but your most valuable information is likely to be stored on spreadsheets.

For precisely this reason, spreadsheets were the killer app for computers in business. Just as email 
encouraged consumers to buy computers and get Internet connectivity, spreadsheets made it 
worthwhile for businesses to buy computers to track how they were doing. Steve Jobs credits the first 
spreadsheet program, VisiCalc, as being the driver for early Apple sales.

Dan Bricklin came up with the idea of a visual calculator in 1978 while doing his MBA at Harvard.123 
He initially visualized the user interface of spreadsheets as the cockpit display in aircraft but settled 
on the current row-column format to enable human-friendly names to be applied to data elements. 
Dan first called his program “Calcu-ledger” but eventually changed it to VisiCalc for Visual Calculator. 
Dan’s business partner, Dan Fylstra, also an MBA from Harvard, and one of the earliest software 
publishers, demonstrated the VisiCalc program to Steve Jobs.124 Almost a million copies of VisiCalc 
were sold at about $100 each, driving sales for Apple, as well as the adoption of computers in business. 
Subsequently, Mitch Kapor and Jonathan Sachs created Lotus 1-2-3,125 which was bought by IBM, and 
Microsoft came out with Excel. VisiCalc eventually lost its lead in the market.

Of all the applications and technologies discussed in this book, the ability to use spreadsheets 
productively is perhaps the most marketable skill. No one will hire you strictly because you can 
write emails or documents. But there is a good chance your expertise in spreadsheets may make you 
extremely valuable for some organizations.

123	 See Dan’s website for his own detailed account of how he came up with the idea of a spreadsheet, 
http://www.bricklin.com/ and http://www.bricklin.com/history/saiidea.htm for the initial idea 
(accessed June 2023).

124	 Steve Jobs’ recollection of the story, “The History of Spreadsheets, from VisiCalc to Causal & 
beyond,” https://callmefred.com/the-history-of-spreadsheets/ (accessed June 2023).

125	 Computer History Museum profile of Mitch Kapor, creator of Lotus 1-2-3, https://computerhistory.
org/profile/mitchell-kapor/ (accessed June 2023).

http://www.bricklin.com/
http://www.bricklin.com/history/saiidea.htm
https://callmefred.com/the-history-of-spreadsheets/
https://computerhistory.org/profile/mitchell-kapor/
https://computerhistory.org/profile/mitchell-kapor/
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What is a Spreadsheet?
A spreadsheet is a computer program that represents information in rows and columns and makes 
it easy to perform calculations with the data.126 In a typical spreadsheet, each column represents a 
different category of data and each row represents a record. For example, a spreadsheet for a sports 
club membership would have one row per student, and one column each for data such as first name, 
last name, sport of preference, email address, phone number, etc.

Spreadsheets are further divided into cells, organized in rows and columns. Rows are numbered and 
columns are named by alphabets, so any unique cell is defined by its row number and column letter. 
For example, in Figure 100, the cell outlined in white is B6, which indicates column B and row 6. The 
column letter always comes first in a cell reference. 

FIGURE 100 — Spreadsheets allow users to organize data efficiently, making it a crucial aspect of businesses. 

Spreadsheets are the workhorses in business for a wide range of tasks, such as budgeting, financial 
forecasting, and data analysis. Spreadsheets include built-in formulas for all the data processing tasks 
common in business. For example, the formula PMT(0.05/12, 60, 3000) will calculate the monthly 
payment for a car costing $3,000 to be paid off in 5 years (60 months) at an annual interest rate of 5% 
(monthly interest rate of 5%/12).127

When working with data, spreadsheets have capabilities that make them far more powerful compared 
to tables in word processing documents. Whereas word processor tables require you to do manual 
calculations on cells of data, spreadsheets allow you to type in a formula to process data from other 
parts of the same spreadsheet or even other spreadsheets. An added advantage of spreadsheets is 
that the results of the formulas will change automatically if any of the input data changes.

Let’s check out a couple of example spreadsheets. Say you are a real estate investor renting out 
multiple properties. To help you focus on your customers and properties instead of your financials, you 
can create a spreadsheet and enter your rental income and maintenance expenses, using formulas 

126	 Spreadsheet definition, adapted from https://www.britannica.com/technology/spreadsheet 
(accessed June 2023).

127	 The payment will be $56.61 per month, for a total payment of $3,396.82. In other words, the 
spreadsheet calculation shows that the buyer will pay almost $400 in interest as the cost of the 
car loan.

https://www.britannica.com/technology/spreadsheet
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to have the spreadsheet automatically calculate the profit/loss from each property as well as the 
overall profit/loss of your company. The spreadsheet will also easily highlight any unusual expenses 
or revenues (Figure 101).

FIGURE 101 — Spreadsheets can benefit a wide range of industries and be customized depending on user needs. 

As another common example, say you are a stock market investor. You can track your portfolios 
by entering the names of companies in your portfolio, the number of shares in each company, the 
purchase price of each share, and today’s market price. Formulas in your spreadsheet can calculate 
your profile/loss for each group of shares, the total profit/loss, and the percent weight of each stock 
by purchase price and by the current market price. This can help you identify winners and losers 
in your portfolio and manage your investments accordingly. Figure 102 shows an example adapted 
from a popular investment management spreadsheet (DR 179).128

FIGURE 102 — Users can track investments using spreadsheets.

128	 DR 179 refers to episode 179 of the Dough Roller podcast. The spreadsheet was introduced 
by the podcast host, Rob Berger, on his podcast in May 2015, https://www.doughroller.net/
podcast/ (accessed June 2023).

https://www.doughroller.net/podcast/
https://www.doughroller.net/podcast/
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In addition to convenient formulas, 
spreadsheets also offer a variety of 
visualization tools like charts and graphs 
that can be used to represent and analyze 
data in intuitive and user-friendly ways. 
Additionally, just like word processing 
software, spreadsheets also support 
collaboration and sharing to allow multiple 
users to work simultaneously on the same 
spreadsheet. Figure 103 shows the portfolio 
distribution (column J) of the spreadsheet 
in Figure 102 as a pie chart. Appropriate 
visualizations can help users get a sense of 
the data. FIGURE 103 — Users can visualize data in spreadsheets. 

Managing Spreadsheets

Managing spreadsheets is much like managing word processing documents. To create a new 
spreadsheet using Google Sheets, go to sheets.google.com and click on “Blank” to open a new sheet. 
To open an existing worksheet, you click on the sheet among your files. Once you have a spreadsheet 
open, you could also create a new one by using the “File” → “New” → “Spreadsheet” menu option. 
You can save any open worksheet the same way you save any electronic document, by clicking on the 
“File” menu and then selecting “Save.” If you would like to change the name of the spreadsheet while 
saving, give the saved spreadsheet the preferred name and choose where you want to save it in your 
Google Drive.

You can share the spreadsheet with colleagues by clicking on the “Share” button and entering the 
email addresses of your colleagues. This will allow your colleagues and friends to access and edit the 
spreadsheet from their own Google accounts.

Spreadsheets typically provide templates for common tasks like managing a monthly budget, a 
team roster, or weekly time sheets. These templates have a predefined look and feel and appropriate 
formulas. Generally, these templates are available from the “File” → “New” dialog as a “Template 
Gallery.” Figure 104 shows the user interface for Google Sheets (top) and Microsoft Excel (bottom).

http://sheets.google.com
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FIGURE 104 — Users can create blank sheets or select a preformatted template. 
(Google Sheets-top; Excel-bottom)

Menu Options

Both Excel and Google Sheets 
provide many menu options to 
simplify complex operations to 
organize and manage data and 
generate output. For example, 
Google Sheets has a standard 
toolbar to format cell contents, 
including font size, currency 
signs, indentation, and 
background color. The “File” 
menu in Google Sheets is used 
to perform file management 
operations, like creating new 
files or opening existing files 
(Figure 105). 

The “Edit” menu in Google 
Sheets is used to copy, paste, 
and find and replace. “View,” as 
the name suggests, is used to 
manage the visible content on 
the screen. “Insert” has options 
to insert rows, cells, columns, 
charts, pivot tables, images, 
and drawings in documents. A 

   

FIGURE 105 — The “File” tab (left) in Google Sheets has a wide variety of 
options and stores many commonly used ones. The “Insert” menu (right) in 
Google Sheets allows users to edit rows and columns.
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common use of the insert menu is to insert charts. If you go to the “Data” menu in Google Sheets, you 
can sort and filter data, set up data validation, cleanup, and perform other operations with the data 
in the spreadsheet. 

As in Google Sheets, Microsoft Excel is feature-rich, allowing you to manipulate data in complex ways 
(Figure 106). The “Insert” tab is also used in Excel to insert images, charts, rows, columns, shapes, and 
pivot tables. 

The “Formula” tab in Excel has many predefined formulas that you can use to perform mathematical, 
financial, and other calculations. You can use the features under the “Data” tab in Excel to import data, 
sort and filter data, remove duplicate values, and set up data validation rules. Under the “View” tab, 
you have options to change the grid layout and freeze different sections of the document. If your 
document has macros (programs to automate spreadsheet tasks), you can view your macros from the 
view menu, and also record new macros. 

FIGURE 106 — In Excel the “Insert” tab (top) displays many features for editing the spreadsheet and adding elements, 
while the “Formula” tab (bottom) helps users preform calculation.

Entering Cell Data

While word processing documents are 
freeform, spreadsheets are structured and 
divided into cells. Once you click on a cell, the 
text you type will stay within the boundaries 
of that cell. 

Spreadsheets are smart and do their best to 
understand what you are entering and give 
appropriate suggestions. One nifty feature 
that helps you copy data or generate a 
series is called autofill. Autofill is the ability 
of spreadsheets to extend a data series (e.g., 
numbers, dates, or text) to neighboring 
cells. Autofill is accessed from the autofill 
handle. If you click on a cell, you will see a 
tiny square box in the lower right corner. This 
is the autofill handle. If you put your mouse 
on the autofill handle, the mouse pointer 
will turn into a cross sign indicating that it is 
ready to autofill. You can drag the cross sign 
to autofill data in neighboring cells. 

The autofill handle in a highlighted cell is located in the 
bottom right corner.

Users can drag the autofill handle to other cells to populate 
data. 
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The autofill concept works across rows too. You can even autofill series across rows and columns at 
the same time (Figure 107). To create an initial series, just enter the first few numbers of the series, 
select the cells, then drag the autofill handle to extend the series. 

FIGURE 107 — Users can autofill multiple rows and columns at the same time by creating an initial copy. 

Autofill can also help you enter a series of 
dates (Figure 108).

Copy/Paste is another great way to enter 
data in spreadsheets. You can copy from any 
location on the web, another spreadsheet, 
or another section of the same spreadsheet 
and paste the data into your spreadsheet. 
When you paste data into a spreadsheet, the 
software will convert the data appropriately 
into cells and rows. If you copy data from 
another spreadsheet, just highlight the 
cells to copy and right-click to bring up the 
context-sensitive menu. You can then either 
cut or copy the selected data and paste it into 
the desired location in your spreadsheet. 

When you paste data in a spreadsheet, you 
have the option to paste just the data values 
or bring along the associated formulas, 
references, and formatting from the source 
spreadsheet. To take advantage of the 
various pasting options, right-click on your 
spreadsheet and choose “Paste Special” 
(Figure 109). 

If your data is in the CSV format, you can 
import it into spreadsheets by choosing 
the import option, generally accessed from 
“File” → “Import” (Figure 110). Excel offers 
a dedicated “From Text/CSV” button in the 
“Data” tab to import CSV. The spreadsheet 
software will let you select any existing data 
source and then walk you through a step-by-
step import process. Data import is useful 
when you collect data from different sources 

FIGURE 108 — Users must create an initial template with 
dates that the autofill feature will use (top). Then the user 
can highlight the cells and auto fill (bottom).

FIGURE 109 — In Google Sheets, users can access special 
pasting options depending on the formatting of the cell. 

FIGURE 110 — Users can import compatible file types into 
an existing spreadsheet. 
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to create your own unified spreadsheet. For example, to create a spreadsheet to plan club meetings, 
you may import club member names from your membership directory and import meeting locations 
from the county’s parks listing.

Row and Column Titles

Row and column titles, also known as labels, are the names/headers that appear at the beginning of 
each column/row in a spreadsheet. These labels are very useful and you should be deliberate about 
their values. Not only do labels make spreadsheets easy to understand, but they are also used to 
identify and describe the rows and columns of data in charts, tables, and other outputs. For example, 
in a spreadsheet containing sales data, the column titles might be different time periods, such as 
“Month,” “Year,” or “Region,” or categories, such as “Sales,” “Profit,” or “Cost.”

FIGURE 111 — When creating labels, users should be concise and clear to ensure 
values are properly represented and the spreadsheet is easy to understand. 

The table in Figure 111 shows Planned and Actual expenses and the column titles are Planned, Actual, 
and Diff. The items for which the cost is tracked, such as Food, Gifts, and Health/medical, are the row 
titles. Column titles are used in conjunction with row titles to provide a complete picture of the data 
in a spreadsheet. Titles can be especially useful when working with complex data sets to help readers 
make sense of the information.

Formatting Cells and Worksheets

To make data easy to comprehend, spreadsheet software provides extensive formatting options. As 
spreadsheets grow large, these formatting options become increasingly critical to understand the 
data. Figure 112 shows some data without formatting. Even though it is a very simple spreadsheet, it 
is difficult to understand what the data says without any formatting.
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Expenses Planned Actual Diff
Totals 0
Food 0 0 0
Gifts 0 0 0
Health/medical 0 0 0
Home 950 1000 -50
Transportation 0 0 0
Pets 0 0 0
Utilities 0 0 0
Travel 0 0 0
Debt 0 0 0
Other 0 0 0
Custom category 1 0 0 0
Custom category 2 0 0 0
Custom category 3 0 0 0

FIGURE 112 — While the data is understandable, 
formatting helps improve clarity and usability. 

  

FIGURE 113 — When data in a spreadsheet 
application is formatted, it becomes easy to identify 
the key features. 

Now let’s use some formatting options and update the same table by adjusting the font size, text 
color, background color, and header elements. You can also include currency symbols and comma 
separators and have the negative numbers show up in a different color. Suddenly, the same data set 
not only looks pretty but also becomes easier to digest (Figure 113).

To format cells in Google Sheets, 
select the cells you want to format 
and choose the “Format” menu 
option. If your cells have numbers, 
you can choose the “Number” option 
and select any one of the available 
formatting options for numeric, 
financial, and date values. You can 
also set the font size, alignment, and 
how data should wrap in a cell.

In Microsoft Excel, you can select the 
cells you want to format, right-click 
to open the context menu, and select 
the “Format Cells” menu option. A 
window opens where you can specify 
several formatting options including 
number display and the look and feel 
of the cells—alignment, font, border, 
or fill (Figure 114).

FIGURE 114 — Excel provides users with many options to format 
cells. 
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Styles

Just as in word processing software, 
styles in spreadsheets are a collection 
of predefined formats that give your 
document a consistent look and 
feel. If you want all your numbers 
to have a currency symbol, two 
decimal places of accuracy, and 
appear in red if negative, you could 
apply the formatting features one 
at a time, which might turn out to 
be cumbersome and error-prone. 
Alternatively, if you are using Excel, 
you could pick an existing “Cell/Table” 
style from the “Styles” group under 
the “Home” tab and apply the selected 
style to cells and tables (Figure 115). 

If the existing styles don’t meet your 
needs, you can create a new style by 
clicking on “New Cell Style” or “New 
Table Style” (Figure 116). Once you 
format the new style by opening the 
formatting window and selecting all 
the features you want, you can give 
the style a new name and reuse the 
style to format any cell or table in your 
sheet. 

If you like the formatting of a cell 
and want to copy it, click on that cell, 
then go to the styles dropdown and 
select “New Cell Style” (Figure 117). 
All the styling features of the cell are 
preselected for you. Just give the style 
a name and use it wherever you want 
unless it is copyrighted material.

FIGURE 115 — Excel offers a wide variety of cell styles. 

FIGURE 116 — Users can create their own cell styles.

FIGURE 117 — Excel allows users to copy formatting used in an 
existing spreadsheet.

Themes

Spreadsheets offer themes to let you 
have a consistent look and feel with 
respect to the choice of colors, fonts, 
cell borders, and background colors. 
Changing a spreadsheet’s theme will 
change the fonts, colors, and effects 
across the entire spreadsheet. In Excel, 
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the “Page Layout” tab has a themes menu with many 
predefined themes (Figure 118). Google Sheets has 
“Themes” under the “Format” menu with a range of 
themes and the ability to customize existing ones. 
As with other properties of spreadsheets, you can 
also change existing themes and create new ones. 

FIGURE 118 — Excel offers users a wide range of 
themes that can be quickly applied. 

Merging and Splitting Cells

Merging cells allows you to combine multiple 
adjacent cells into one cell. This technique is 
particularly useful when creating a header row for 
a table in a spreadsheet (Figure 119). 

In the “Expenses Table,” even though all the rows 
have the same number of cells, the title row 
appears to be a single cell because several cells 
have been merged to create one cell for the title. 
To merge cells in a spreadsheet, you can select 
the cells that you want to merge and then use the 
“Merge Cells” command. This will combine the cells 
into a single cell and adjust the formatting of the 
merged cell to match the formatting of the first cell 
in the selection. In Google Sheets, you find “Merge 
cells” under the “Format” menu and Microsoft Excel 
has various options to merge and unmerge cells on 
the ribbon under the “Home” tab (Figure 120). Expenses Table

Totals
Planned Actual Diff

$1,000 $1,050 -$50
Food $350 $375 $25
Gifts $300 $300 $0
Health/Medical $350 $375 $25

FIGURE 119 — Headers can be created by merging 
cells.
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FIGURE 120 — In Google Sheets (top), the merge cell feature is in the format menu. In Excel (bottom), the merge cell 
feature is under the home tab.

Keep in mind though that you can’t merge cells 
that don’t form a proper rectangle, as in Figure 121.

If things change, you can use the “Split Cells” 
command to split a merged cell back into its 
original cells. This can be useful if you want to make 
changes to the individual cells within the merged 
cell. 

FIGURE 121 — These cells can’t be merged as they 
don’t form a rectangle or square. 

Hide and Unhide Columns and Rows

Spreadsheets can easily expand to fill many 
columns and rows. But your monitor typically only 
allows a few rows and columns to be visible at a 
time. Spreadsheets have an interesting capability 
to hide rows and columns to allow you to focus on 
the columns and rows of interest. To hide a column 
in Google Sheets, simply click on the column letter 
at the top of the spreadsheet and choose “Hide” 
(Figure 122). If you are using Excel, go to the “Cells” 
group under the “Home” tab and click “Format.” 
In the “Visibility” section, you will see “Hide” and FIGURE 122 — Users can hide columns to better 

manage large volumes of data.
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“Unhide.” You can also click on the column 
or the row header to select a column or row, 
then right-click to bring the context menu 
and select “Hide” or “Unhide.” 

When columns or rows are hidden, you 
will see a break in the sequence of column 
headers or row numbers. In Figure 123, 
column G is missing. Clicking on the gap will 
unhide the column. In our experience, it is 
far more common to need to hide columns 
than to hide rows.

FIGURE 123 — Users can hide columns to better manage 
large volumes of data.Page Layout Options

Users often want to print out spreadsheets 
to present to managers or other decision-
makers. Spreadsheets allow you to format 
and preview the spreadsheet for printing. The 
page layout determines how a spreadsheet 
will look when printed. As a spreadsheet 
is a collection of cells organized into large 
numbers of rows and columns, printing it 
can be a challenge unless you set it up well. 
To solve the problem, spreadsheet software 
gives you page layout options that will allow 
you to have a presentable look when you 
print it on paper or view it as a PDF. There 
are many ways to get to the “Page Layout” 
option and many features to consider. In 
Excel, click on the “Page Layout” tab, then 
in the “Page Setup” group, click the “Dialog 
Box Launcher” in the bottom right corner to 
bring up the page setup dialog (Figure 124).

You can also make a few quick choices 
directly from the “Page Layout” menu 
options (Figure 125).

FIGURE 124 — In Excel users can change the page layout to 
make their data easier to print or export. Opening the “Print 
Titles” launcher (top) allows users to specify “Page Setup” 
requirements (bottom).

FIGURE 125 — Excel page layout options. 
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Here are a few things to consider to make your spreadsheet visually appealing.

Page orientation: Just like word processing software, spreadsheets can have either portrait 
(vertical) or landscape (horizontal) orientation. In Excel, the “Page Layout” tab has menu options 
to set the orientation. In Google Sheets, when you select “File” → “Print,” you see a “Print Preview” 
of the pages and have the option to adjust the paper size, orientation, headers and footers, grid 
visibility, alignment, and other properties.

Page size: You can specify whether you want to print/export your spreadsheet to PDF as a letter 
sized, A4 sized, or any of the other standard or customized paper sizes. 

Margins: You can adjust the size of the margins to have the look you want.

Headers and footers: You can add headers and footers to the top and bottom of each page. 
In Excel, go to the “Insert” tab and click on the “Header & Footer” menu to insert headers and 
footers. As mentioned earlier, in Google Sheets you can add headers and footers, page numbers, 
workbook tiles, and other information when you try to print the document. 

Page breaks: You can insert page breaks to control where the spreadsheet gets divided across 
multiple pages when it is printed/exported.

Gridlines: If you want, you can choose to display gridlines on the printed/exported version of 
the spreadsheet.

Scaling: You can adjust the scaling of the spreadsheet to fit it on a specified number of pages by 
making it a percentage of its original size.

Formulas and Functions

You can supercharge your spreadsheet by employing formulas and functions to calculate values using 
the data in cells. Formulas are simple. When you write a formula in a cell, you begin with the equals (=) 
sign and specify the cells to use for the calculation and what operations to perform on the data. For 
example, if you want to add the values in cells A1 and B1, you could type the following formula in any 
cell “=A1+B1.” The result will get displayed in the cell where you type the formula.

If you have a table with your daily expenses, you can use a formula to calculate the sum of all your 
expenses. The total cell in Figure 126 has the sum of expenses (=B13+B14+B15+B16). As you enter the 
formula and press “Enter,” you will get the total. As you change the data in cells, the calculations change 
automatically, which makes spreadsheets a 
very powerful tool. If you want to calculate 
the average daily expense over a month, 
you can add the daily total expense for a 
month and divide it by the number of days 
in the month. As soon as you enter a new 
set of values for the next month, you will 
immediately get the new daily average. 

Spreadsheets also have powerful functions 
ranging from simple functions like Sum, 
Average, Count, Max, and Min to complex 
engineering, statistical, math, and financial 

FIGURE 126 — Spreadsheet formulas allow users to quickly 
perform calculations with the help of visual aids. 
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functions. To use the sum function to 
add your expenses in Figure 126, just 
type =SUM(B13:B16). To access the “SUM” 
functions in Google Sheets, select a range 
of cells and click “Insert” → “Functions”→ 
“SUM.” In Excel, functions are located under 
the “Formulas” tab and are further organized 
by financial, logical, text, date & time, math 
& trig, and other menu options (Figure 127).

FIGURE 127 — Both Excel (top) and Google Sheets (bottom) 
offer a range of formulas to perform calculations. 

Charts and Images

Charts offer a graphical representation of 
data and can help analyze data in a more 
meaningful and visually appealing way. 
You might not see a pattern or discrepancy 
by staring at 1000s of numbers, but a chart 
can bring out anomalies to the forefront 
quickly. In the language of British journalist 
and author David MacCandless, charts 
allow you to use the language of the eyes 
(pictures) along with the language of the 
mind (numbers), greatly speeding up data 
comprehension.129

To create a chart, select the data that you 
want to include—a range of cells or a 
table—then use the charting tools in the 
spreadsheet software. In Google Sheets, 
you can use the “Insert” → “Charts” option 
to bring up an interactive tool that lets you 
pick the chart type you want (Figure 128). 
Bar charts, line charts, pie charts, and scatter 
plots are each suited for different types of 
data and can help you visualize information 
in different ways.

It is important to identify the chart type 
that will be most useful for a given task. 
For example, if you are trying to chart your 
school expense in Figure 128, let’s consider 
some options. 

FIGURE 128 — Navigate to the chart menu to select a chart 
type. 

129	 The beauty of data visualization, TED talk by David MacCandless in 2010, https://www.ted.com/
talks/david_mccandless_the_beauty_of_data_visualization. David also maintains a website 
with novel visualizations at https://informationisbeautiful.net/ (accessed June 2023).

https://www.ted.com/talks/david_mccandless_the_beauty_of_data_visualization
https://www.ted.com/talks/david_mccandless_the_beauty_of_data_visualization
https://informationisbeautiful.net/
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Expense data can be compared using bar charts.

   
Pie charts allow users to visualize percentages.

A line chart is a good choice for showing trends over time, and a scatter plot is good at showing the 
relationship between two variables. So, if you wanted to compare your expenses against an average 
student’s expenses, you may consider a scatter plot (Figure 129 and Figure 130).

  

FIGURE 129 — A table of expenses. 

   

FIGURE 130 — Scatter plots allow users to compare 
two or more sets of data. 

Once you create a chart, you can customize it by changing the appearance and layout of the chart 
and adding labels, titles, and data markers. 

Benefits of Charts

Charts can give users a quick visual summary of large volumes of data. A well-known example to 
demonstrate the utility of charts was published in 1973 by Yale statistician Francis Anscombe and is 
popular as Anscombe’s Quartet.130 The quartet consists of 4 sets of 11 numbers each, with very different 
distributions but almost identical statistical properties. While the differences are not readily apparent 
from the data, the differences are immediately apparent from a chart. The data and their charts are 
shown below. The mean and variance of y for each series are 7.5 and 4.125. The example is meant 
to show that though numerical data is considered precise, and charts are considered approximate, 
charts help with analysis and detecting the underlying phenomena.

130	 Anscombe, F. J. (1973). “Graphs in Statistical Analysis,” American Statistician. 27 (1): 17–21. See also 
the Wikipedia page on “Anscombe’s Quartet” at https://en.wikipedia.org/wiki/Anscombe%27s_
quartet (accessed June 2023).

https://en.wikipedia.org/wiki/Anscombe%27s_quartet
https://en.wikipedia.org/wiki/Anscombe%27s_quartet
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I II III IV
x y x y x y x y

10.0 8.04 10.0 9.14 10.0 7.46 8.0 6.58
8.0 6.95 8.0 8.14 8.0 6.77 8.0 5.76

13.0 7.58 13.0 8.74 13.0 12.74 8.0 7.71
9.0 8.81 9.0 8.77 9.0 7.11 8.0 8.84

11.0 8.33 11.0 9.26 11.0 7.81 8.0 8.47
14.0 9.96 14.0 8.10 14.0 8.84 8.0 7.04
6.0 7.24 6.0 6.13 6.0 6.08 8.0 5.25
4.0 4.26 4.0 3.10 4.0 5.39 19.0 12.50

12.0 10.84 12.0 9.13 12.0 8.15 8.0 5.56
7.0 4.82 7.0 7.26 7.0 6.42 8.0 7.91
5.0 5.68 5.0 4.74 5.0 5.73 8.0 6.89

Anscombe’s Quartet data series

The series is plotted in Figure 131. It becomes immediately clear that the series is describing different 
phenomena and that there are outliers in some data series that merit further investigation.

       

FIGURE 131 — Anscombe’s Quartet showing how graphs make differences in data patterns readily apparent.

Images

While charts are graphs created based on 
the data in your spreadsheet, images are 
pictures you can directly insert into your 
spreadsheet. In Google Sheets, you can 
click on any cell and then choose “Insert” 
→ “Image.” If you choose to insert the 
image in a cell, then it is constrained by 
the dimensions of the cell. If you choose to 
insert it over cells, then the picture floats on 
top of cells and can be sized independently 
of the underlying cells. In Excel, you can go to the “Insert” tab and click on the pictures menu to insert 
pictures in your spreadsheet. Inserting images adds organizational branding to spreadsheets.

Google Sheets offer users the ability to insert images over 
cells or in cells.

Share and Collaborate

Just like word processing documents, you can share spreadsheets with others in your team, so more 
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than one person can view and edit the 
spreadsheet in real-time. In Google Sheets, 
you will see the “Share” button on the top 
right side of your screen.

Clicking “Share” will open a window 
where you can enter your team members’ 
email addresses and make them viewers, 
commenters, or editors.

As the names imply, editors can edit the 
content, commenters can add comments, 
and viewers can see the changes. 

If you use an online version of Excel 
(OneDrive, SharePoint, or Excel for the 
web), you can share it with teams, and the 
changes made by each member will be 
visible to others.

The Share button in Google Sheets allows users to send 
copies or collaborate on spreadsheets. You can specify 
the level of permissions shared users have regarding the 
document.Analyzing and Organizing 

Data

Filters

If you have a humongous spreadsheet, you may find it useful to look at a narrower set of data to 
focus your attention on one or two aspects of the data. By applying a filter, you can choose which 
rows are visible and which ones are hidden. 
Keep in mind, filtering doesn’t change the 
underlying data. Only the data set that 
matches the filtering criteria gets displayed. 
When you remove the filters, you will have 
the original spreadsheet with all the rows, 
just as before.

For example, you may have your company’s 
sales data for every Division, Sub-Division, 
and product (Figure 132). If you want to 
focus only on the data for your Division, 
Sub-Division, or product, setting up a filter 
may be a great idea. 

In Google Sheets, click on the filter icon and 
select “Create new filter” view. Then click on 
the column header of any column to filter 
data (Figure 133). 

Division
Sub-
Division

Product 
Number

Number 
of Units

Price 
per 
unit

east 1 1111 140 $10
west 2 1111 21 $9
west 3 1111 18 $12
east 3 1111 16 $8
west 1 1111 11 $10
east 4 1111 11 $9
west 3 2222 16 $12
west 2 2222 15 $10
east 2 2222 15 $11
west 1 2222 12 $10
east 3 2222 12 $9
east 4 2222 12 $9
east 1 2222 10 $9
east 2 2222 9 $13

FIGURE 132 — When working with large sets of data, users 
may choose to filter specific columns. 



188 Chapter 9—Introduction to Spreadsheets

FIGURE 133 — Google Sheets provides users the ability to filter data, making large datasets easier to use.

To create a filter on the division column, 
click on the column header “Division.” If you 
only want to see sales data for the West 
Division, you should deselect “East” and click 
“Ok” (Figure 134). When you create filters in 
Google Sheets, the sidebars change in color 
to indicate that a filter is in place (Figure 
135).

You could create additional filters on top of 
an existing one. For example, if you wanted 
to only see a particular Sub-Division within 
your Division, you can create a filter on 
the “Sub-Division” column (Figure 136). 
Removing the filters will bring the original 
data and the color changes back to normal. 

To filter in Excel, select any cell within the 
range of data. Then go to the “Data” tab and 
click on the “Filter” menu. On the column 
headers, you will see the option to filter.

FIGURE 134 — Once in the “Create new filter” view of 
Google Sheets, users can filter columns of data.

FIGURE 135 — Once a filter has been established, you only 
see the data you are interested in.

FIGURE 136 — Users can filter multiple columns at the 
same time.

Sorting 

Sorting organizes data in an ascending or 
descending order and facilitates searching 
for data. Some spreadsheet operations such 
as VLOOKUP and Remove Duplicates also 
expect data to be sorted. For example, if 
you have a list of students with First Name, 
Last Name, City, and GPA in a spreadsheet, 
it may be useful to group all the students in 
a city together. Just sort the data by City to 
reorganize the underlying data and see all 
the students from one city in one place. If 
mayors want to award the top-performing 
students in their cities, they can sort by City 
and then by GPA to figure out which students 
will receive awards. If you choose to sort 
from the largest to the smallest (descending 
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order), the student with the highest GPA will be at 
the top. 

Just like Filtering, Sorting doesn’t alter the 
underlying data. What you change is how rows get 
ordered compared to the other rows in the data 
set.

To sort by Division in Google Sheets, we simply 
select the column and then do “Data” → “Sort” 
(Figure 137). 

If you want to do more complex sorting (first by one 
column, then by another), in Google Sheets simply 
select the cells that comprise your data set and 
choose “Data” → “Sort Range” option. “Advanced 
range sorting options” will let you sort by as many 
columns as you like (Figure 138). 

In Excel, go to the “Data” tab and click “Sort” to open 
the “Sort” window and sort by as many columns as 
you like. Don’t forget to select the checkbox “My 
data has headers,” if your top row has headers. This 
will make sure only the data gets sorted, not the 
headers. 

Division
Sub-
Division

Product 
Number

Number 
of Units

Price 
per unit

east 1 1111 140 $10
west 2 1111 21 $9
west 3 1111 18 $12
east 3 1111 16 $8
west 1 1111 11 $10
east 4 1111 11 $9
west 3 2222 16 $12
west 2 2222 15 $10
east 2 2222 15 $11
west 1 2222 12 $10
east 3 2222 12 $9
east 4 2222 12 $9
east 1 2222 10 $9
east 2 2222 9 $13

Division
Sub-
Division

Product 
Number

Number 
of Units

Price 
per Unit

east 1 1111 140 $10
east 2 1111 21 $9
east 3 1111 18 $12
east 3 1111 16 $8
east 1 1111 11 $10
east 4 1111 11 $9
east 3 2222 16 $12
east 2 2222 15 $10
west 2 2222 15 $11
west 1 2222 12 $10
west 3 2222 12 $9
west 4 2222 12 $9
west 1 2222 10 $9
west 2 2222 9 $13

FIGURE 137 — Unsorted sales data of a company 
(top); Data sorted by Division (bottom). 

FIGURE 138 — In Google Sheets, users can 
simultaneously sort multiple columns by utilizing 
the “Advance range” sorting options.

Conditional Formatting

Conditional formatting allows you to apply 
formatting, such as cell shading and text color, to 
cells based on conditions. This can be useful in 
highlighting important information or for making 
data easier to read and understand. You can use a 
formula or a set of rules to determine which cells 
should be formatted. 

Going back to our company sales data, let’s say we 
want to highlight any sales of more than 15 units 
in green and those with less than 10 units in red. In 
Google Sheets, select the cells you want to format, 
then choose “Format” → “Conditional Formatting” 
(Figure 139). In the conditional formatting window, 
make sure the cells you want to format are selected, 
then create rules to see the formatting results 
(Figure 140). 

In Excel, the “Conditional Formatting” menu is 
under the “Home” tab. Just select “Highlight Cells 
Rules” and create the conditional formatting rules 
you want. 



190 Chapter 9—Introduction to Spreadsheets

FIGURE 139 — Conditional formatting helps 
identify cells that meet specific requirements.

Division
Sub 
Division

Product 
Number

Number 
of units

Price 
per 
unit

west 2 1111 21 $9
west 3 1111 18 $12
west 3 2222 16 $12
west 2 2222 15 $10
west 1 2222 12 $10
west 1 1111 11 $10
east 1 1111 140 $10
east 3 1111 16 $8
east 2 2222 15 $11
east 3 2222 12 $9
east 4 2222 12 $9
east 4 1111 11 $9
east 1 2222 10 $9
east 2 2222 9 $13

FIGURE 140 — Users can specify colors to 
represent cells that meet specific criteria. 

Pivot Tables

A pivot table is a useful tool to quickly summarize and 
analyze large amounts of data to see patterns and 
trends. Manually analyzing the data in a spreadsheet 
with 1000s of rows spread across tens of columns 
can be a daunting task. If you want to see patterns, 
compare the impact of different columns, or group 
data in categories, you may need to put in months of 
painstaking work. Using pivot tables, you can simply 
select all your data, transpose it to a pivot table, select 
columns to categorize on, filters to apply, and choose 
the summarizations you want. The software will do 
the calculations and give you a pivot table summary 
report. If you don’t like the outcome or if you want to 
change your filtering, grouping, or summarization parameters, you can do so and immediately see 
the outcome. 

Additional Resources

Spreadsheets have a wide range of capabilities for a wide array of applications. To become proficient 
at using spreadsheets, consider using them anytime you are working with numbers. Like any skill, 
practice will improve your ability to leverage this highly valuable technology.

Several influencers share valuable Excel tips on social media sites, including Twitter. Some threads the 
authors can recommend are below:

15 Excel tips: https://twitter.com/FluentInFinance/status/1611807041399705600

Search by hashtag for Excel: https://twitter.com/hashtag/excel.

https://twitter.com/FluentInFinance/status/1611807041399705600
https://twitter.com/hashtag/excel
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			   Chapter Terms and Definitions

Cell: A cell is a single element in the worksheet 
that has a value, some text, or a formula

Chart: A type of visualization shaped like a pie 
and used to analyze data in an intuitive and user-
friendly way

Column: Represents categories of data and the 
cells are named by alphabet vertically

Conditional Formatting: A spreadsheet feature 
that allows you to apply formatting options, such 
as cell shading and text color, to cells based on 
conditions

Data: Information used for reasoning, discussion, 
or calculation

Filter: A spreadsheet feature designed to narrow 
a set of data based on specific criteria so that you 
can choose which rows are visible and which 
ones are hidden

Formula: A feature that performs specific 
calculations or other actions on the data in the 
spreadsheet

Function: A set piece of code built into a 
spreadsheet that performs certain predefined 
actions; examples include SUM, AVERAGE, 
COUNT, MIN, and MAX

Pivot Table: A useful tool to quickly summarize 
and analyze large amounts of data to see patterns 
and trends

Row: Represents a record of data and the cells 
are numbered horizontally

Sorting: A spreadsheet feature that organizes 
data in an ascending or descending order and 
facilitates searching for specific data

Spreadsheet: A computer program that 
represents information in rows and columns, and 
makes it easy to perform calculations with the 
data
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		  	 Chapter Case

Sports Tracking Spreadsheet
Kenny needed to take on a volunteer project to help with his future chances of 
getting a college scholarship. Most of the college scholarships he was interested in 
applying for required that he have a minimum number of documented volunteer 
hours. Thankfully, a local non-profit youth sports management organization 
needed to create a spreadsheet that would help track students who sign up for 
various youth sports. 

Kenny offered to help the organization create the spreadsheet in exchange for 
documented volunteer hours. The manager of the organization agreed to the 
project and Kenny was ready to apply his spreadsheet skills. 

The spreadsheet required the tracking of the following data: 

·	 Student First Name

·	 Student Last Name

·	 Student Age

·	 Student Grade

·	 Student School

·	 Telephone Number

·	 Sport (Volleyball, Basketball, Softball, Baseball, Soccer, or Football)

Question 1:	 Considering the data required in the list above, create a spreadsheet 
in a spreadsheet application you have access to. Add at least 10 
rows of data to your spreadsheet. Once you add all the data to the 
spreadsheet, what is the average age for all the students? What 
formula did you use to calculate the average age? 

Question 2:	 Add a chart to the spreadsheet that illustrates the total number 
of students for each sport. Which sport has the highest number of 
students? What formula did you use to count the total number of 
students for each sport?
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